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1 Introduction 

KINGUI 2 is a software tool for determining kinetic parameters from results of environmental fate 
studies, e.g. aerobic soil degradation, by fitting respective mathematical models to the observed 
data. It consist of two parts, first a package of numerical methods for the actual calculations, 
implemented in R (R language for statistical computing and graphics, http://www.r-project.org/), 
and second a graphical user interface for project administration, parameterization of the 
optimization runs and result evaluation. 

The optimization workflow and the evaluation of results is optimized to account for the 
requirements given by the FOCUS Report on Estimating Persistence and Degradation Kinetics 
(EC Document Reference Sanco/10058/2005, version 2.0, June 2006). Thus it provides all 
kinetic models recommended in this report and by default does the standard statistical 
evaluations requested. 

In Version 2 KINGUI allows the choice between different optimization algorithms. In particular the 
estimation of parameter confidence intervals is much improved as compared to the previous 
version by providing the methods Iteratively Reweighted Least Squares (IRLS) and Markov 
Chain Monte Carlo (MCMC). 

 

1.1 Workflow 

 Create ‘R’-script files (with the GUI or with a simple text editor like notepad++) 

 Run them with ‘R’ having the KinGUI 2 packages and sourcefunctions installed 

 Get the resulting reports and graphs with the KinGUII ResultViewer 

 

The graphical user interface ‘KinGUII’ is so to say a specialized text editor for ‘R’-script files. With 
the intuitive ‘R’-script language you are also able to write the scripts with a normal text editor and 
run them form the DOS command line. Results can be viewed using the KinGUII ResultViewer. 

 

 

http://www.r-project.org/
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2 Installation  

2.1 Workflow 

No real installation process necessary! 

 Check if .NET framework v 4.0 (or later) is installed 

 Copy program files to your local hard drive 

 Dblclick ‘..\KinGUII\GUI\KinGUII.exe’ to start the GUI’ 

 

2.2 Requirements 

 .Net framework version 4.0 or later. Download here the version for your  
language settings (~ 48MB). 
 

 

 
 ~ 140 MB harddisk space  

 No installed version of ‘R’ necessary 

 No Admin rights necessary! 

 
 

 

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=en
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2.3 Installation 

Copy source (SourceDrive:\KinGUII) incl. subfolders to your local drive  

 Do not use network drives! 

 Do not use system paths like ‘C:\Program Files’ or ‘C:\WINDOWS’ 

 Check access rights to target path 

 

The resulting directory structure should look like this: 

 

Start GUI 

Start Result Viewer 

File->Preferences->Paths 
Path to R 

Project->Paths->Trial path 
Path to your trial directory 

File->Preferences->Paths 
Path to Working Directory 

 

Dblclick ‘..\KinGUII\GUI\KinGUII.exe’ to start the GUI’  
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3 Getting started 

3.1 Workflow 

 Check preferences (paths to ‘R’ and ‘Working Directory’) 

 Set Trial path and name 

 
3.2 Set ‘R’ and ‘Working Directory’ 

Check/set paths to the main ‘R’ directory and to the ‘Working Directory’, where your projects will 
be saved (normally these paths are already chosen by the program). You have to do this only 
once, your selections will be saved to program settings automatically. 

 

 

You can find a description 
for the value in the selected 
field here. 

DblClick here to auto adjust 
the width of the fields  
(‘EXCEL like’) 

 
3.3 Set Trial - name and path 

 

Used to construct ‘R’-script file name: 

Comments taken from 
residue data file. 
Can be extended at any 
time 

Type ‚?’ to get a directory 
browse dialog. 
Directory structure: 
Working Directory 
    -> (opt.) Project path 
              ->Trial path 

‘TrialName’ ‘Optimizer’ ‘Kinetic model parent’ ‘parent compartment name’ .r 
e.g.: ‘TestTrial IRLS DFOP Parent.r‘ 
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4 Data management 

4.1 Workflow 

 Prepare ASCII text- file with residue data 

 Load data to workplace 

 Assign compartment residue data to pathway position 

 Connect compartments 
 

4.2 Preparation of residue input data 

 Plain ASCII text-file 

 Comment lines must contain "#", ":" or "/" 

 You may have as many comment lines as you want 

 No empty lines allowed! 

 1st data column must always contain the sampling times, header for this column must be 't' 
or 'time' 

 No special chars for compartment names (e.g. space, "?", "\", "*" etc.) 

 Data delimiter :TAB   

delimiter between data colums,  

there may be more than one TAB between two values (for alignment reasons) 

 No comments in data rows 

 Residue data must be sorted by sampling times 

 Missing data can be left blank or marked as ‘NaN’ (‘not a number’) 

 No columns with weights for your data points (will be edited later, std. value = 1) 

No empty lines, use ‘#’ 

1st column with sampling 
times and header = ‚t’ or 
‚time’ 

No comments in data section 
Data sorted by sampling time 

TABs as data delimiter 

Comments will be taken as 
project comments 

 
Example:  
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4.3 Load residue data  

 

 

 

 

 

 

 

 

 

 

4.4 Assign residue data to pathway positions 

 

 

Residue data file 

Define compartment name  
No special chars!  
(like *, #, space, -, ? etc) 

Select compartment 

Assign pathway position 
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4.5 Weights 

 

 

Set weight to 
 1/ (Residue Data) 

R-Script ‘part’ for the 
residue data 

Set one weight for all data 
points of the compartment 

See/edit weights for each 
data point 

 

Re-assign compartment 
after changing values 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Important: If you change the weights always (re)assign the compartment to the desired 
pathway position to apply the changes! 
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4.6 Connect Compartments 

Just click on the gray arrows to change the compartment connection 

 

 1st Click: Connect compartment (black arrow) 

 2nd Click: Change direction of the connection 

 3rd Click: Break connection (grey arrow) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.7 Save/Load Workspace as XML-file 

The complete workspace (model structure and data allocation but excluding project settings) can 
be saved or loaded at any time to/from an xml file. 

 

  

 

 

 

 

 

4.8 Reset Workspace 

To start form scratch without closing and reopening the program click File-> Reset Workspace  
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5 Kinetic input 

5.1 Important 

Always click into this field before leaving this form, otherwise your changes will be lost! 

If the form is not responding please close and reopen this dialog! 

 

You can check the data input by leaving the entry screen and selecting “View-> R-Script” to see 
the script file that also echoes the input data. 

 

5.2 Workflow 

 Parent 

o Input: 

 kinetic model: SFO, DFOP, FOMC or HS 

 ‘M0’ (total amount of chemical present at time = 0 days) 

 formation fraction 
 

 Metabolite 

o Only SFO is allowed 

o Keep M(0) of the metabolite fixed to zero (unless there is reason to do otherwise)  

o Choose formation fraction 

 
 Define ‘Optimizer’-Settings 

o Optimizer  std  = ‘IRLS’ (Iteratively reweighted least square) 

o Method  std  = ‘solnp’ 

o Submethod std  = ‘Port’ 
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5.3 Kinetic parameters 

All kinetic parameters have the same data structure 
 
Fixed  ‘TRUE’ or ‘FALSE’ 

 std. value =’FALSE’ 
 Select or unselect the “fixed” checkbox for each parameter 
 => not fixed : parameter is optimised, starting with the initial value 
 => fixed : parameter is not optimised, but kept at the initial value 
 
Initial Value  >= 0 

 Enter a (reasonable) initial value for each parameter 
 See what the graph would look like with the initial values you have chosen 
 Use Mouse Wheel or direct user input 

 
 

 

Lower Bound >= 0 
 std. value = 0  

 
Upper Bound >= 0, incl. ‘Inf’ for infinity 

 std. value = ‘Inf’ 
 For the formation fractions, the default upper boundary is 1 
 
 
5.3.1 Input helper 

 
DblClick on 

 ‘M0’ to set the total amount of chemical present at time = 0 days to the  
1st residue data point (only for Parent) 

 Any formation fraction (initial value input field) to distribute the formation equally 
between all metabolites (and sink, if defined) 

Use mouse wheel or direct user input to change initial values for kinetic parameters 

See what the graph would look like with the parameters you have chosen as initial values. 
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5.3.2 Parent 

Select kinetic model. 
Always click into this field 
before leaving this form. 

DblClick on any ‚Initial Value’ 
input field to distribute 
formation fraction equaly 
between the metabolites and 
sink (if defined) 

Watch changes to the graph 
while changing the initial 
values for kinetic parameters 

See residue data details for 
the compartment  

Use Mouse Wheel or direct 
user input to change initial 
values for kinetic parameters 

DblClick to set M0 to 1st 
residue data value 
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5.3.3 Metabolite 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Keep M(0) of the metabolite 
fixed to zero (unless there is 
reason to do different). 

Graph of residue data 

For metabolites only SFO is 
defined. 
Always click into this field 
before leaving this form. 
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5.3.4 Optimizer Settings 
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Optimizers 

Three options are available: 

 NLLS: Classical Nonlinear Least Squares method as implemented in KinGUI 1 

 IRLS: Iteratively Reweighted Least Squares. Improved algorithm that more realistically 
estimates parameter confidence intervals (see. Gao et al., 2011, "Improving Uncertainty 
Analysis in Kinetic Evaluations Using Iteratively Reweighted Least Squares" submitted to 
Environmental Toxicology and Chemistry). 

 MCMC: Markov Chain Monte Carlo method for determination of parameter distributions 
(see: Görlitz et al., 2011, "Statistical Analysis of Chemical Transformation Kinetics using 
Markov-Chain Monte-Carlo Methods", Environ. Sci. Technol., 45 (10), pp 4429–4437). 
CAUTION: This method is very time consuming. 

 

For all other setting the default values should be used in first instance. Changes should only be 
made if no successful optimization is achieved. Choosing other methods will usually result in 
significantly increased processing times. 

For the description of the different methods the user is referred to the descriptions of the 
respective R-packages. 
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6 ‘R’-Script 

The R-Script contains all parameters and setting for running an optimization. It can be viewed by 
clicking “R-script” under the “View”-option. 

The following explains the structure of the R-Script and how it is compiled with KINGUII. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.1 Metadata 

Comments are taken from your residue data file. You can add further comments via 
Projects->Metadata->Comments. 
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6.2 ‘Residue data, pathway and kinetics’ 
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6.3 ‘Fit and optimizer’ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.4 ‘Output’ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Result file names (kgo, kgg): 
‘TrialName Optimizer’ ‘Kinetic model parent’ ‘parent compartment name’ .kgx 
e.g.: ‘TestTrial IRLS DFOP Parent.kgo’ 
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6.5 ‘Run’ 

For running an optimisation simply press “Run” 
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7 Results 

The KINGUIIResultViewer is started by “View” -> “Results”. 

The result viewer presents graphs of the observed and calculated data as well as the residuals 
separately for each compartment (choose under “Compartment”) and different views on the 
calculated results and the underlying R-script.  

All data can be copied or saved after right click on the respective window panel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: The result viewer can also be used independently by starting “KINGUIIResultViewer.exe” 
and loading the R-file of which the results shall be viewed. 
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7.1 MCMC  

 

For runs with MCMC additionally a correlation and a density graph is available. 
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